
Exercise 4  (v.2023a) 

Temperature distribution and thermal stresses 
 

 
Introduction 

 
The finite element method allows you to effectively calculate thermal stresses. Thermal strains due to thermal 
expansion in a three-dimensional, isotropic body are described by the strain vector: 
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The total strains are then the sum of thermal strains and elastic strains (caused by a stress field): 
𝛜 = 𝛜 ் + 𝛜 ௌ 

The problem of thermal stresses is usually solved in two steps: 
1. Solution for resultant temperature in a stationary problem ( steady state ) or in a transient heat flow. The 

results are saved in the jobname.rth file 
2. Solving the problem of stress analysis including a thermal load – i.e. taking into account additional nodal 

forces resulting from temperature changes. These forces are calculated basing on information about nodal 
temperatures from the jobname.rth file 

 
The heat conduction equation has the form: 
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In the finite element method, instead of a PDE, an equivalent formulation of the minimization of the functional is used, 
which after discretization is transformed into a system of algebraic equations. The finite elements used in the 
calculation of temperature fields are corresponding to the finite elements constructed for stress analysis and have 
analogous shapes, numbers of nodes and shape functions. At each node, we only have one degree of freedom. Usually, 
solving the conduction equation using FEM is not a problem. 
 
boundary conditions that may occur in the calculations : 
1. temperature 
2. heat flux density (W/m 2 ) 
3. heat flux (nodal force) 
4. Newton's law of convection: 𝑞 = α௞(𝑇௕ − 𝑇ௌ) 
5. radiation 
 
The properties of a medium may be functions of temperature. The boundary conditions can be variable in time, applied 
in shocks ( Step- Loads ) or gradually ( Ramped-Loads ). In the case of complex processes, the course of changes in 
boundary conditions is presented as a sequence of subsequent loading steps ( Load Steps ). Calculations of transient 
temperature fields also require initial conditions. 
  



 

The first case – temperature and stress in the steady state 

Thick-wall pipe – thermal load 
 
inner radius: a = 30 mm 
external radius: b = 40 mm ( length is arbitrary, e.g. = 60 mm) 

internal surface temperature:  𝑇௪ = 100௢𝐶  
external surface temperature:  𝑇௭ = 20௢𝐶 
 

Material : 
 
steel E = 200 GPa 
ni = 0.3 
alpha = 1.2e-5 1/K 
lambda = 50 W/(m K) 

 
The temperature distribution should be calculated, as well as the stress distributions: circumferential σ௧, radial σ௥, 
axial σ௭and equivalent stress HM. Assume initially that the pipe cross-sections remain in a plane state of 
deformation. 
The analytical solution shows that σ௧(𝑎) = −150.2𝑀𝑃𝑎,σ௧(𝑏) = 124.1𝑀𝑃𝑎. 
FEM calculations will be performed for the option: three-dimensional pipe section. 
 

 NOTE on the choice of set ofunits: SI (N, m, s, W, kg) or mod_SI (N, mm, s, mW , tons) .  
 
 
Temperature distribution calculation: 

Preprocessor : 
0. Preferences – (set BOTH types of analyses: Structural  and Thermal )) 
1. Geomety  

Modeling > Create > Volumes > Cylinder > By Dimensions ( cylinder length 60 mm = 0.06 m, angle 90 deg) 
2. Material properties: E, nu , lambda, alpha (NOTE the units: SI or mod_SI ) 

Material Properties > Material Models > Structural > Linear > Elastic > Isotropic 
Material Properties > Material Models > Structural > Thermal Ex. > Secant Coeff. >Isotropic 
Material Properties > Material Models > Thermal > Conductivity > Isotropic    

3. Element choice 
Element Type > Add > Thermal Mass > Solid ( select Brick20node - 279) 

4. Meshing into finite elements ( HEX elements, i.e. Mapped division ) 
Meshing > Mesh Tools > Lines - Set > Pick All ( division everyone lines for 8 elements ) 
Meshing > Mesh Tools > Volumes ( note : select HEX!!) Check List>Elem ( how many elems ?) 

Solution 
5. Specify the type of analysis 

Analysis Type > New Analysis > Steady State 
6. Introduction of boundary conditions: temperatures on the inner and outer surfaces of the pipe 

Define Loads > Apply > Thermal > Temperature > On Areas 
      Check !: List > Loads > Solid Model Loads (how many/ which surfaces should there be ??) 
  Area numbering: Plot> Areas and PlotCtrls > Numbering … and Replot 

7. Calculation of the temperature distribution inside of solid (thru-thickness plot) 
Solve > Current Load Step 
 



General Postprocessor 
8. Assessment of heat flow results and preparation of plots illustrating the solution 

Plot Results > Contour Plot > Nodal Solution > DOF Solution > Nodal temperature 
9. Temperature graph along the pipe thickness  

steps for: defining the path, mapping the temperature along 
the path and presenting it in the form of a graph: 

a. PathOperations > Define Path > ByNodes  (indicate 2 nodes, 
on internal and external surface and Name the path) 

b. Map onto Path  (Name the variable e.g. T_r and select 
DOF: Temp) 

c. Plot Path Item > On Graph ( select T_r ) 
 
All thermal analysis results are written in the jobname.rth file 
and will be used to determine thermal loads during stress 
analysis. 

 

 
Calculating the stress distribution: 
After evaluating the temperature distribution results, we move back to the Preprocessor. Convert the FE to a stress 
analysis model - i.e. change the element type (with the same meshing) 

Preprocessor : 
10. Change a Thermal Solid element to the corresponding Structural Solid element 

Element Type > Switch Element Type > Thermal to Struc . 

Solution 
11. Introduce the displacement boundary conditions on 4 surfaces (four FLAT cross-sections) of the model 

Define Loads > Apply > Structural > Displacements > Symmetry BC > On Areas 

12. Enter the loads in the form of nodal temperatures obtained as the result of heat flow analysis ( jobname.rth 
file) - as loads in the stress analysis: 

Define Loads > Apply > Structural > Temperature > From Thermal Analysis ( plus Solution Opts – Output Ctrls ) 
13. Calculation of the stress and displacement field 

Solve > Current Load Step 

General Postprocessor 
14. In the case of cylindrical pipe, it is convenient to use RSYS1 to present the results: cylindrical coordinate system 

(default is: Z axis along the cylinder axis): 
     Option For Output > Results Coordinate System ( set  Global Cylindrical) 
15.  Evaluation of the results in the form of a stress and displacement map and graphs 

       Plot Results > Contour Plot > Nodal Solution > DOF Solution 

  
(Sample maps below - in SI units) 

 
 
 
 
  



The second case - transient states of temperature and stress 

Hardening of the steel ball 
 
Radius = 6mm   (only 1/8 of the ball is analyzed due to symmetry) 
initial temperature of the ball: 𝑇௣ = 850௢𝐶  
oil temperature (constant): 𝑇௢ = 40௢𝐶 
 
 

Ball material : 
 
E = 2e5 MPa (change to SI units) 
nu = 0.3 
density = 7800 kg/m 3 
coef. thermal expansion (CTE)  = 1.2e-5   1/K 
coef. heat conduction k = 40  W/(m K) 
specific heat c = 444  J/(kg K) 
film coeff. (convection heat transf)  α = 400  𝑊/(𝑚ଶ𝐾) 

 

 How long should the ball stay in the oil bath to reach a temperature of 100 degrees inside? 
 When will the maximum equivalent stress in the ball occur? 

The most interesting parameter in the example is:  the temperature variation on the surface and inside the ball 
 

 NOTE on the choice of units : SI (N, m, s, W, kg) or mod_SI (N, mm, s, mW , t).  
 

Temperature distribution calculation: 

Preprocessor :  
0. Preferences – (set BOTH analyses: Structural  and Thermal )) 
1. Geometry  

(we create object through the intersection of the sphere and the hex-block) 
Modeling > Create > Volumes > Sphere > By Dimensions 
Modeling > Create > Volumes > Block > By Dimensions 
Modeling > Operate > Booleans > Intersect > Common > Volumes 

2. Determination of material properties: E, nu , rho , lambda, alpha 
Material Properties > Material Models > Structural > Linear > Elastic > Isotropic 
Material Properties > Material Models > Structural > Density 
Material Properties > Material Models > Structural > Thermal Ex. > Secant Coeff. >Isotropic 
Material Properties > Material Models > Thermal > Conductivity > Isotropic 
Material Properties > Material Models > Thermal > Specific Heat   (different value for mod_SI !!! ) 

3. Element choice 
Element Type > Add > Thermal Mass > Solid 279 

4. Meshing into finite elements – all lines into 12 elements (HEX, Mapped mesh )  
Meshing > Mesh Tools > Lines - Set > Pick All > No of element divisions = 12 
Meshing > Mesh Tools > Volumes 

Solution 
5. Specifying the type of analysis 

Analysis Type > New Analysis > Transient 
6. Introduce the THERMAL boundary conditions at the external surface of the analyzed object (convective heat 

exchange on the OUTER surface) 
Define Loads > Apply > Thermal > Convection > On Areas  (… Select Area.)   > Film Coeff. = 400 and BulkTemp =40    
                                                                                                        (numeric values - different for mod_ SI units!!! 0.4 ) 

7. Enter the reference temperature and initial temperature 
Define Loads > Settings > Uniform temp. (850 C) 
Define Loads > Settings > Reference temp. (40 C) 



8. Set the transient analysis details for the job  
(final time = 60 s, number of substeps = 300, Stepped impact load , results written for each substep ) 

Load Step Opts > OutputCtrls > DB/Results File > Every substep 
Load Step Opts > Time/ Frequenc > Time and Substeps > end = 60; substeps = 300, Stepped; automatic time 
stepping = off   

9. Calculation of the temperature field 
Solve > Current Load Step 
 

General Postprocessor 
10. For a selected substep (or better - for chosen time points) – evaluate the results,  

Read Results > By Pick 

TimeHist Postproc 
In this post-processor you can list or graph 
the results as functions of time. In the 
drawing on the right: a graph of the 
temperature difference between the node 
at the surface and in the center of the 
sphere. 

a. Name the values in nodes (plus sign icon) 
b. Name for the math operation 
c. Create an expression - difference of variables  

by inserting variables from the drop-down field  
and using the calculator 

d. Hit ENTER on the calculator 
e. Create a chart (the third icon - after the plus sign ) 

 
 

NOTE:  
the max value on the graph should be ca. 22.5 deg) 

 
Calculating the stress state:  
The procedure is the same as in the case of a thick-walled pipe (see points 10-15 for the thick-walled pipe): 

Preprocessor: 
11. Change a Thermal Solid element to the corresponding Structural Solid element 

Element Type > Switch Element Type > Thermal to Struc  

Solution 
12. Set the symmetry displacement boundary conditions on the cross-sectional (flat) surfaces of the model 

Define Loads > Apply > Structural > Displacements > Symmetry BC > On Areas 

13. Enter the thermal loads - nodal temperatures obtained as a result of heat flow analysis ( jobname.rth file ) as 
loads in the stress analysis. Enter the time for which thermal loads are to be read (as time , e.g 48 sec): 

Define Loads > Apply > Structural > Temperature > From Thermal Analysis 

14. Change the analysis type to Static and delete substeps (see point 8: Time over Substeps : e.g 48 and 1) 
15. Calculate the stress and displacement field 

Solve > Current Load Step 
 

General Postprocessor 
16. Evaluate the results in the form of a stress and displacement map and graphs 

a. Option For Output > Results Coordinate System > spherical 
  (you may need to load current results:  Read Results >Last step) 
b. Plot Results > Contour Plot > Nodal Solution > DOF Solution 



 
Sample results for typical moments (old results ??): 
 

 
 
 

Temperature distribution ( C) and von Mises stress (Pa) after 1 s (???) of cooling 
 
 

 

 
 

Temperature distribution ( C) and von Mises stress (Pa) after 48 (???) seconds of cooling. 

 
 
 
 
 

Discussion of the results for the report: 

1. The first Case:  
Distribution of temperatures, displacements and stresses for a THICK-WALL PIPE ( Map of temperatures, 
displacements, radial, circumferential, axial and reduced stresses) 
 
2. The second Case:  
Distribution of displacement, temperature and equivalent stresse for a HARDENED BALL for time steps    
(t=1 sec , t=48 sec ) 
 
And of course, Interpretation of the results 
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